Jump to content

Recommended Posts

My name is Marco and I am new here. Just recently got a 2012 Gear up. First tiem Ural owner and have been going through "Helga" just getting to know her and making sure things are right.

 

Kinda flat acceleration after 2nd gear and can hardly get past 50 mph. Did a tune and now I am in process of getting new jets and cleaning up tank and fuel system. Really enjoying just spending time getting familiar with my Ural and feeling like I will be able to pull off most maintenance myself. I am no mechanic but handy enough I hope.

 

Thanks in advance to you all.

 

Marco

Link to post
Share on other sites

Welcome, Marco.

Make sure to adjust the valves, too. They are the most likely tune-up item to change, and require adjusting.

And fortunately very simple to adjust, after some practice.

 

Your description of poor acceleration and 50 mph max does indicate the engine is not running properly.

A check of the ignition timing might be in order, too.

Please keep us posted on your progress.

RussN

Link to post
Share on other sites

My name is Marco and I am new here. Just recently got a 2012 Gear up. First tiem Ural owner and have been going through "Helga" just getting to know her and making sure things are right.

 

Kinda flat acceleration after 2nd gear and can hardly get past 50 mph. Did a tune and now I am in process of getting new jets and cleaning up tank and fuel system. Really enjoying just spending time getting familiar with my Ural and feeling like I will be able to pull off most maintenance myself. I am no mechanic but handy enough I hope.

 

Thanks in advance to you all.

 

Marco

 

Marco, Curious to know what you have ordered for jets. I just can't seem to get my 2008 Tourist to run without bogging and popping. Be interested in whether the re-jet solves your problem.

Link to post
Share on other sites

My name is Marco and I am new here. Just recently got a 2012 Gear up. First tiem Ural owner and have been going through "Helga" just getting to know her and making sure things are right.

 

Kinda flat acceleration after 2nd gear and can hardly get past 50 mph. Did a tune and now I am in process of getting new jets and cleaning up tank and fuel system. Really enjoying just spending time getting familiar with my Ural and feeling like I will be able to pull off most maintenance myself. I am no mechanic but handy enough I hope.

 

Thanks in advance to you all.

 

Marco

 

Marco, Curious to know what you have ordered for jets. I just can't seem to get my 2008 Tourist to run without bogging and popping. Be interested in whether the re-jet solves your problem.

 

While I have not needed to jet my '07 and therefore have no idea what is in it... I doubt the jets changed in a year... tho I do Not Know..

I replaced my stock petcock, the terrible Vacuum operated one... with a manual one from???? maybe a Suzuki??? Maybe someone will remember that "change"

and would never Dream of an Inline fuel filter.. they have caused me more grief than function...

Couple things to look at...

Link to post
Share on other sites

Fuel system and petcock cleaned. New fuel lines. Timing correct. Carbs synchronized and idling at 9K RPM. New plugs. Air filter clean and very lightly oiled. New jets 130/45.

 

Seems really good until hitting 4th gear around 45 mph and then just barely get past 50.

 

Tried it with 2 shims and with no shims and still same.

 

I removed the tiny washers from the pilot screw since they were little lock washers and left the tiny O rings. Should I put those back?

 

No burping or farting except maybe a tiny one after shutting off.

 

What now?? Increase fuel mix?

 

Just enjoy 50 mph?

 

I guess I could change petcock but it seems to have plenty of fuel in first 3 gears.

 

I'm not using an in line filter.

Link to post
Share on other sites

Oiled air cleaner???? See how it goes without air cleaner in the box... Briefly...

I do Not believe in any but K&N air filters... and never sponges!!! Even Paper [dry of course] beats a Sponge..

If you are in a very dusty environment... get a Quality Precleaner...

Link to post
Share on other sites

I could have bought a 2017 Saharra fully loaded for about 5 grand more than this. Starting to regret going the cheaper route

bs.gif

I'm stumped and starting to get a little bummed. I have balanced carbs, throttle cables, and idle adjustment screws are exactly the same on each carb for idle at 10K rpm. Valves are adjusted per specs. New plugs. Timing set. fuel system entirely cleaned. tires psi correct. All fluids new.

 

She has run pretty consistently well regardless of what I do in first 3 gears and a dog in 4th. Pulling in clutch in 4th lets engine rev up much higher so there is fuel but something is restricting acceleration. No umph with throttle maxed but it flies away as soon as I pull clutch.

 

Went back to 40 pilot jet and kept in 130 main with 2 turns out of idle adjustment screws and also 2 out on pilot needles. No shims. Still seems fine until 4th gear.

 

If it were related to petcock wouldn't it starve out in any gear when rpm increase?

 

I don't think it is related to carbs. I'm gonna get the richness nailed and quit *%%@king with the carbs and move on to compression testing, u joints, and brakes I guess.

 

Drive to sidecar should turn even when 2 wheel drive not engaged, correct?

 

Back at it tomorrow!

Link to post
Share on other sites

If it runs out in 3rd gear... but can't pull 4th... Pull clutch and tell how it Coasts... in 4th

Sounds like something Physical... maybe even gearbox...or final drive dragging...

 

 

BTW

did you try running w/o air filter???

sounds more and more like something else... but easy ###### first!!!

Link to post
Share on other sites

Marco,

 

Compression test would've been the first thing I would do on a "new" to me Ural. I would then clean the gas tank, clean or swap the petcock, fuel lines, then do throttle cables adjustments, carb cleaning, synchronization, etc.

I would've also run fuel lines to carbs without filters, and try testing the bike without air filter at least to make sure filters are not restricted.

 

If you used the kill switch and coasted at highest speed in 4th gear...what color were your plugs?

I know you are looking to purchase a new coil. Do you have good spark on both sides?

 

There are diagnostic spark testers you can use before buying new coil, wires, ignition:

https://www.amazon.com/Wei-Xi-Fool-Proof-Diagnostic-Automotive/dp/B0793MMHYR/ref=asc_df_B0793MMHYR/?tag=hyprod-20&linkCode=df0&hvadid=242087006306&hvpos=1o11&hvnetw=g&hvrand=9888610638722351779&hvpone=&hvptwo=&hvqmt=&hvdev=t&hvdvcmdl=&hvlocint=&hvlocphy=9031188&hvtargid=aud-801738734305:pla-451732415479&psc=1

 

 

P.S. Would've check/tide down all four rockers before doing valve adjustments. Head torque:

Link to post
Share on other sites

I bought a used 2013 with carb problems. First I installed a Yamaha gravity petcock $30, then went to an independent Harley shop equipped with a dyno. He gave me an analysis for 40 bucks. Too lean. I ordered a CV stage Kit from Ebay for under a hundred bucks. After a 45 min installation I returned to the dyno 32rwhp 32tq he charged me nothing. Money well spent, my bike is a solo if it wasn't I'd had removed the sidecar until the problem were solved. Checking timing, coil, valves, battery voltage and compression is always a good start. https://www.ebay.com/itm/Ural-Gear-Up-Sidecar-Twin-750-cc-Performance-Carburetor-Carb-Stage1-3-Jet-Kit/253980948095?hash=item3b2271b67f:g:eB8AAOxySy9SRbgx

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...