Jump to content

Search the Community

Showing results for tags 'fi'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Admin/Moderator Forum
  • Forum Terms and Rules
    • Forum Terms and Rules
    • Forum Issues and Suggestions
  • Russian Iron Motorcycle Club
    • Russian Motorcycle World
    • Rides and Rallies
    • Owner Classified
    • Dealer Classified
    • Nuts 'n' Bolts
    • Projects, Restorations and Rebuilds
    • Russian Iron Down Under
    • Russian Iron Scandinavia
    • Russian Iron Netherlands
    • Vintage/Classic Bikes of Interest
    • Whatever
    • Rant 'n' Rave
  • Board /Club Info. FAQs
    • The Russian Iron Motorcycle Club and the Ride for Kids

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


My Bike(s)


My Story

Found 1 result

  1. I sure could use some help. I running a 2014 MIR with fi. It's the same as the Patrol. When it's cool the engine will not catch unless I give it a slight throttle, which I should do with fi. When it does start, giving it throttle stalls. After it is somewhat warm it runs but backfires. After it is fully warm it runs well. The dealer installed the latest map but had no answers. It also lacks power which I expected, but cruising at 65 mph and going up a slight incline, about 5 degrees I can barely maintain 45. Any idea would be much appreciated.
×
×
  • Create New...